Bring back the old Calendar sync function

I miss the days, when my Pipedrive activity was synced to Google calendar with all the important info. For example, when I scheduled a Call in Pipedrive, in my calendar, it would show up as "Call>Mr. President>US Governement Ltd."

The way it works now, all I can see in my calendar is "Call", or "Meeting" but nothing more. Unless of course I manually rewrite the subject of the activity inside Pipedrive.

The fact that you have dropped this awesome functionality is for me a reason, that I slowly cease using Pipedrive and I am looking for an alternative... I was an early adopter, I was with Pipedrive from its very beginning, when I was directly communicating with Martin Henk and the other guys... 

0 votes

· Last Updated -


  • Inês Batata
    Inês Batata Admin Posts: 3,155 COMMUNITY MANAGER
    2500 Comments Second Anniversary 5 Likes First Answer
    edited April 29 #2

    Hi @František Soumar !

    Thank you for your feedback and for illustrating your use case so clearly. I'm going to forward it internally to our team for consideration.

    ALternatively, you can see the name of the person and Organization linked to your activity in the Deal, Person or Organization's detail view, and also in the Activities List View (by pulling up the respective columns from the cogwheel icon).





    If you'd like to explore the Advanced plan, it allows you to create a Workflow Automation that automatically names your activities using placeholders like the ones you mentioned (among others), and you also get the Scheduler, which reads your Pipedrive calendar and helps you avoid double-bookings and saves you time in the back-and-forth trying to find a good time to meet with a customer or a prospect.

    Hope that helps!

  • Mikk Mangus
    Mikk Mangus Posts: 1
    Pipedrive Employee
    edited April 29 #3

    Hi @František Soumar!


    There is an option to turn on syncing the relative information about the activity to external calendar on calendar sync settings page.

    Do you have that turned on?

    Settings > Tools and Apps > Calendar sync