I have noticed that the deal specific email address no longer shows in deals when created. Is there a way to enable this? I cant see it in the settings.