Pipedrive android app not installing on samsung s7, what are the minimal requirements?

Hello, I am concerned about which cell phones are compatible with the android application, two of my agents have Samsung s7 and the application is not compatible. Is there somewhere where I can see the requirements for the app to work for them? I don't want to invest in cell phones that won't work later. Thank you in advance for some direction.

Best regards

Peter from Chile.

Tagged:

Best Answer

  • Manuel Oliveira
    Manuel Oliveira Admin Posts: 803
    500 Comments 100 Likes Second Anniversary 5 Answers
    COMMUNITY MANAGER
    #2 Answer ✓

    Hi @Peter from Chile , please check if your cell phones can be updated to at Android version 9 or later, as that is the earliest version supported by the Pipedrive mobile app at the time of this comment. In case you update to this version or a later one, but the Pipedrive Android app still isn't listed on the Google store, that means the device is not supported.

Answers

  • Peter from Chile
    Peter from Chile Member Posts: 4
    First Comment

    I discover that, the cellphones than i have can just be update to version 8, yeah i know they are old ones. So i find older pipedrive app and installed, its working right now. I am pretty sure iam losing some capabilities, but its ok for now.

    Than you for ur answer.

    Saludos desde Chile!