Email Automations & Preventing team members from moving deals backwards

Options
Dael Redmond
Dael Redmond Member Posts: 3
First Comment Photogenic
edited April 24 in Workflow Automation #1

Hi all,

As Pipedrive does not have the option to prevent deals being moved backwards in Pipedrive, we set up the following automation which works great.

Automation 1 - Prevent Stage Moving 1-2 day follow up backwards

However, needing some assistance to prevent an email automation sending the client the same email twice. This occurs when a sales rep accidently moves a deal backwards (from 1-2 day follow up to appointment set) and the above automation is triggered and moves it back (from appointment set back to 1-2 day follow up), therefore triggering the same email automation to send again. Is there a workaround to this?

I have tried delays etc but would love some assistance, suggestions or ideas to work around this as both automations are important.

Answers

  • Lucas MAGNE
    Lucas MAGNE Member Posts: 163
    First Anniversary First Comment 5 Likes 5 Up Votes
    Options

    Hi,

    I'm not sure to understand your problem but trying an answer 😅

    At each time that an email is sent thanks to your automations, you can create an activity with a specific type or subject after that action.


    On the same automation you can use another condition which is "Filter" does not match to "Filter name". (Community on my example).

    This filter will be a filter on your deals with the conditions "Activity : Subject or Type is not ...


    And so, at each time that a deal move to your specific stage, the automation will check if the deal is not on your filter :

    • If not, the email will be sent
    • If yes, that means that the deal has already received your email because there is the activity into the deal and it has been filtered.

    I hope this explanation answers your question!

    Do not hesitate to come back to me if necessary.

    Have a great day ! 👋

  • Dael Redmond
    Dael Redmond Member Posts: 3
    First Comment Photogenic
    Options

    Thanks - in the activity type - you have selected email. I dont have this option, how do I make it available?


This discussion has been closed.