Zapier not bringing in the owner

David Schuster
David Schuster Posts: 2
edited July 24 in Apps and Integrations #1

Hey Team,

Having some issues getting zapier to pull in the correct info from Sierra Interactive into PipeDrive.

1st Issue

In the example below, the data in shows the correct owner of the deal, Ashley Key. But the data out defaults back to the account owner, Dan Ellison. I also included an image of the zap field in question.

image

 

image

 

image

2nd Issue

Second issue I'm having is assigning a newly created contact to a newly created deal. There is no variable field under "2. Find or Create Person in Pipedrive" to assign the new contact to the deal (I've clicked show all options).

image

 

Thank you!



bbAr2W
pgMZVv
lfAdaM
ExdGtb

Comments

  • Land Geek Guys
    Land Geek Guys Posts: 1
    edited February 24 #2

    Hey there, 

    Instead of using the user name "Ashley" try using their Pipedrive user ID in the field. 

    I ended up having to add a lookup table step so that I could convert the name into the Pipedrive owner ID. Then you use the output from the lookup in your deal step. See below. 

    image

     

    image

    I think for your second issue, it's because you haven't sent sample data through, so it isn't returning a field for you to use. I'm not sure though. 

  • David Schuster
    David Schuster Posts: 2
    edited June 2020 #3

    Hey there, 

    Instead of using the user name "Ashley" try using their Pipedrive user ID in the field. 

    I ended up having to add a lookup table step so that I could convert the name into the Pipedrive owner ID. Then you use the output from the lookup in your deal step. See below. 

    image

     

    image

    I think for your second issue, it's because you haven't sent sample data through, so it isn't returning a field for you to use. I'm not sure though. 

    Thank you! The lookup table worked perfectly!

    For the second issue, I added a Find Person step after the Find/Create Person step and got it to work.