my email tracking doesnt work to show when a contact opens an email

Options
Damian Frost
Damian Frost Member Posts: 4
First Comment
edited July 2022 in Sales CRM #1

 my email tracking doesnt work to show when a contact opens an email and its a mess so not sure if this feature is a failure for others or if i am doing something wrong .  it also doesnt allow me to forward a template email to new contacts and leads as they come in because for some reason it doesnt link the contacts email it uses the subject line which means you cant forward template emails from outlook. one contact in my PD has every welcome template email i have ever sent to all the new leads under his name in PD.... could someone please tell me that it is possible to clean this up and have it function properly because im thinking of getting rid of this feature altogether. many thanks 

Comments

  • Mike van der Valk
    Mike van der Valk Pipedrive Team Posts: 3,072 PIPEDRIVE TEAM
    First Anniversary 5 Likes 5 LOLs First Answer
    edited February 2022 #2
    Options

    Hi @Damian Frost 

    We haven't had any problems with our email tracking, just to be sure I'd recommend to reach out to our support via live chat in-app or support@pipedrive.com

    Regarding the template problem. The thing is when you use the "forward" option the sync sees this as a new email in the same thread and that's why it's linked. If you'd start a brand new email and then copy the template text in there it sees it as a new one and would separate it and link it to the contact it was sent to.

    I can best suggest you to use the Pipedrive email template that automatically fills in certain data fields from your customer. You can then use the workflow automation to automatically send templates if needed as well when you have a new contact/deal for example.

  • Damian Frost
    Damian Frost Member Posts: 4
    First Comment
    edited December 2020 #3
    Options

    Hi @Damian Frost 

    We haven't had any problems with our email tracking, just to be sure I'd recommend to reach out to our support via live chat in-app or support@pipedrive.com

    Regarding the template problem. The thing is when you use the "forward" option the sync sees this as a new email in the same thread and that's why it's linked. If you'd start a brand new email and then copy the template text in there it sees it as a new one and would separate it and link it to the contact it was sent to.

    I can best suggest you to use the Pipedrive email template that automatically fills in certain data fields from your customer. You can then use the workflow automation to automatically send templates if needed as well when you have a new contact/deal for example.

    thanks Mike ill check it out... im aged 100 when it comes to technology 

This discussion has been closed.