Pipedrive overwriting decimal prices containing '.0' when typing.

Daniel Smith_6998
Daniel Smith_6998 Posts: 15
edited July 6 in Sales CRM #1

Hi there. 

Rather than me try and explain in a wall of text, please see the attached video of me trying to type 1.08 and 0.08, into the Price field of the 'Add Products to Deal' modal.

Essentially, this occurs any time I, or one of my employees, try and type any decimal figure into this price field, that contains '.0'

1.1 types fine, 1.2 types fine, anything that doesn't contain '.0' in it types fine. But as soon as you type '.0', Pipedrive replaces the decimal point and zero with a blank.

So for example, if you type '0.08', with each subsequent keypress the field will show '0', then '0.', then blank, then '8'. You can see this in the video attached.

I have attempted to self diagnose, and this behaviour is:

  1. consistent
  2. replicable across multiple users using the browser-based interface.
  3. does not appear to be linked to the Keyboard or Language settings inside Windows.
  4. only occurs inside Pipedrive, nowhere else.

Help!?

For clarity, my keyboard language per Windows settings is 'US (QWERTY)'.

bandicam 2021-02-16 13-59-43-476.mp4
Tagged:

Comments

  • Mike van der Valk
    Mike van der Valk Posts: 4,376 PIPEDRIVE PRODUCT MANAGER
    2500 Comments 25 Likes Second Anniversary First Answer
    edited July 1 #2

    Hi @Daniel Smith 

    Sorry to hear that!! I was just able to reproduce this. I'll pass it on to our team so they can create a bug and work on fixing this. Apologies and thank you for writing us.

  • Isabelle Bailleux
    edited June 28 #3

    Hi @Daniel Smith 

    Sorry to hear that!! I was just able to reproduce this. I'll pass it on to our team so they can create a bug and work on fixing this. Apologies and thank you for writing us.

    @Mike van der Valk Still not working

  • Mike van der Valk
    Mike van der Valk Posts: 4,376 PIPEDRIVE PRODUCT MANAGER
    2500 Comments 25 Likes Second Anniversary First Answer
    edited July 1 #4

    Hi @Daniel Smith 

    Sorry to hear that!! I was just able to reproduce this. I'll pass it on to our team so they can create a bug and work on fixing this. Apologies and thank you for writing us.

    Hi Isabelle,

    Sorry about that. We're in the middle of updating our deal views and will tackle this too.