My leads don't have marketing consent even though they are opting in

Jacqui Evans
Jacqui Evans Posts: 5
edited May 18 in Sales CRM #1

Hi There,

My incoming leads (from web forms) are not coming in as having 'marketing consent' even though they are checking the 'opt-in' check box in the form. How can I fix?

Tagged:

Comments

  • Edie Mew
    Edie Mew Posts: 148
    100 Comments First Answer 5 Up Votes 5 Likes
    edited April 27 #2

    Hi @Jacqui Evans  do you have a custom field to capture their answer?

  • Janis Rozenblats
    Janis Rozenblats Posts: 197 PIPEDRIVE PRODUCT MANAGER
    100 Comments Second Anniversary Name Dropper Photogenic
    edited April 27 #3

    Hi @Jacqui Evans this might be helpful ;)https://support.pipedrive.com/en/article/web-forms#consent-fields-for-web-forms
    If you are using Campaigns, then webforms will have a marketing status field that can be added to the webform for option.

  • Aleksandrs Vilums
    Aleksandrs Vilums Ex-Pipedrivers Posts: 22 PIPEDRIVE PRODUCT MANAGER
    Photogenic First Anniversary Pipedrive Employee
    edited April 27 #4

    Hi, @Jacqui Evans & @Edie Mew 

    You can get your form contacts marked as Subscribed (single opt-in). Do do so:

    1. Go to your Web Form -> edit. 
    2. Click on [+] to add a new block
    3. In block Input field select Person -> Marketing status field name.
    4. Save

    Contacts now will have the option to select a checkbox if they want to be subscribed to marketing newsletters:

    • If contact will select the checkbox, it will be added with Marketing status Subscribed.
    • If contact will not select the checkbox, it will be added with Marketing status No consent.


    Later you will have option to find how many Subscribed and No consent Marketing status contacts you have, filter those and so on. 

    ! To use Subscribed contacts, be sure your company has Pipedrive by Campaigns enabled. 

    N.B. Now with Pipedrive Web Forms you can add single opt-in subscribed contacts. Double opt-in option is not available yet.